Patch Numbers for ADF Runtime Libraries Update to

After the release of the new JDev version I ask support for the patch numbers for the ‘Sherman Update 2’, which seams to be the official name.
Support just answered my question:

The 2 patches are :


But I need confirmation if it can be installes on top of WLS
as from the crertification matrix it is only certified on top of WLS :
Oracle JDeveloper Certification Information

So lets hope we can somehow update the WLS 10.3.5 server with installed ‘Sherman Update 1’๐Ÿ™‚

UPDATE May-10-2012:
Got this from support regarding upgrade of an existing WLS 10.3.5 server:

There was a confusion if could be installed on top of WLS as per the cerfification matrix is only certified for WLS

I got confirmation that ADF requires the Application Development Runtime libraries.
ADR can be installed on WLS 10.3.5 or WLS 10.3.6
So can be installed on top of WLS

UPDATE May-19-2012:

I got some more info about the possible upgrade path from Oracle I like to share:

Q1) Are the ADF ADF Runtimes certified against WLS 10.3.5?

Yes and we’ve updated the cert matrix to reflect this:

Q2) Is there a patchset to move from or to

No. As you’ve correctly identified, the only way is to install the Runtimes then apply the patch.

The release notes do highlight this fact, but do not mention that there isn’t a patch from to I’ll seek to get a clarification put in the release notes.

Q3) If is a patch on top of are all of the features available to

No. The patch overrides functionality in so customers should not assume this.

The answer to Q3) is probably the interesting one as it makes clear that even as we update from, we don’t get the features introduced with in JDev๐Ÿ˜ฆ
One other implication is that you can’t run applications from both versions on one WLS 10.3.6 server.

10 thoughts on “Patch Numbers for ADF Runtime Libraries Update to

  1. Hi Timo,

    for WLS 10.3.5 Users Oracle says on its release page for the following

    “Key Installation steps for EXISTING Oracle WebLogic Server Users
    Ensure server is an 11g Release 1 Patch Set 5 ( Application Developer shiphome. Patch Set 5 itself will be available in both a “patchset” form as well as a “full” install. Customers using a version of Application Developer shiphome prior to Patch Set 5 will need to upgrade their environment to Patch Set 5 before installing Sherman 11.1.2. For more information see the Oracle Fusion Middleware Patching Guide.
    Download the Sherman 11.1.2 Opatch bundles and use the opatch tool to apply the patches.
    ADF patch bug #13656274 and WebCenter patch bug #13656372
    Shutdown the target domain servers.
    Run the WLST “upgradeADF” command in offline mode.
    Restart the servers.”


    Good luck!๐Ÿ˜‰ And keep us up to date about your patching progress…


    • Andreas,
      thanks for pointing to the obvious document to look at for the patch numbers. 2nd time this happens to me๐Ÿ™‚

      The interesting part is that the release notes assume that we update from JDev only. Up to now I had the impression that JDev 11.1.1.x and JDev 11.1.2.x are two development branches which (hopefully) will be merged in JDev 12c. Now, after reading the releas notes I wonder if the changes and new features introduced in JDev are part of the JDev release too. This seams not the case when reading the What’s New doc.

      Let’s hope MOS will shed some light into this. See, the SR is not that bad๐Ÿ™‚


  2. Hi Timo,

    I use with Weblogic 10.3.6.
    I already update adf runtime to patch “Patch 13656274: SHERMAN UPDATE2: RT BASED ON JDEVADF_11.” as your post here.
    I also already invoke a command : “upgradeADF(‘path_to_domain’)” in wlst offline mode.

    But, when I start EM, I found a problem says:
    “java.lang.VerifyError: oracle/adfinternal/view/faces/renderkit/html/customizable/ShowDetailFrameRenderer: attempting to override final method org/apache/myfaces/trinidad/render/CoreRenderer.decode(Ljavax/faces/context/FacesContext;Ljavax/faces/component/UIComponent;)V”

    Do you have any idea about this problem?

    I appreciate your help. Thank you.



  3. hi timo, my name is moulali, i am getting a problem deploying ADF application on weblogic10.3.6 server
    my jdeveloper version is i have ADR but i am unable to find patch
    to install on top of ADR. please provide me a proper link to download patch.
    thanks in advance.

  4. Hi Timo,
    I have installed both sherman patch on my weblogic 10.3.6
    my jdeveloper version is, i am able to deploy ADF war file on Admin server, but
    when i am trying to deploy on managed server i am getting the following error.

    12:29:18 PM] —- Deployment started. —-
    [12:29:18 PM] Target platform is (Weblogic 10.3).
    [12:29:23 PM] Retrieving existing application information
    [12:29:23 PM] Running dependency analysis…
    [12:29:23 PM] Building…
    [12:29:24 PM] Deploying profile…
    [12:29:25 PM] Wrote Web Application Module to C:\JDeveloper\mywork\ADFLayout\Project1\deploy\webapp1.war
    [12:29:25 PM] Deploying Application…
    [12:29:26 PM] [Deployer:149191]Operation ‘deploy’ on application ‘webapp1’ is initializing on ‘ADFServer’
    [12:29:26 PM] [Deployer:149193]Operation ‘deploy’ on application ‘webapp1’ has failed on ‘ADFServer’
    [12:29:26 PM] [Deployer:149034]An exception occurred for task [Deployer:149026]deploy application webapp1 on ADFServer.: Failed to load webapp: ‘webapp1.war’.
    [12:29:26 PM] Weblogic Server Exception: weblogic.application.ModuleException: Failed to load webapp: ‘webapp1.war’
    [12:29:26 PM] Caused by: Error: Unresolved Webapp Library references for “ServletContext@30185606[app:webapp1 module:webapp1.war path:/ADFLayout-Project1-context-root spec-version:2.5]”, defined in weblogic.xml [Extension-Name: jsf, Specification-Version: 2, exact-match: false]
    [12:29:26 PM] See server logs or server console for more details.
    [12:29:26 PM] weblogic.application.ModuleException: Failed to load webapp: ‘webapp1.war’
    [12:29:26 PM] Deployment cancelled.
    [12:29:26 PM] —- Deployment incomplete —-.
    [12:29:26 PM] Remote deployment failed (oracle.jdevimpl.deploy.common.Jsr88RemoteDeployer)

    • You have to install the ADF runtime onto the managed server too. To do it manually you can target the shared libraries to the managed server. The easy way would be to use the enterprise manager which should offer you a task to install the libraries onto the managed server.

      • Hi Timo,
        I am totally new to ADF ,i have applied JRF to my managed server by Enterprise manager ,how to install ADF runtime onto managed server even though i have created managed server from MW_HOME/oracle_common/common/bin/ file, how to target the shared libraries to the managed server manually, how to use the enterprise manager which offer a task to install the libraries onto the managed server..
        please.. please reply me in detail i am really new in this, i not getting any solution from google also,
        what output should we get on upgradeADF(‘domain path’)..
        please help me.
        Thanks in advance.

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s